Coda File System

5.3. Configuring a FreeBSD kernel

All modern releases of FreeBSD (3.x and 4.x) already include all necessary to configure kernel for Coda client. Using Coda client under FreeBSD, you have two options: either to use Coda kernel loadable module ( KLD ), or to build custom kernel with Coda support. First option doesn't require any significant changes to your installation and can be used on systems without source code installed.

Loading Coda kernel module. To experiment with Coda client, you can load Coda KLD using following command: kldload coda . To verify that module is loaded run kldstat , coda.ko should be listed in its output, which could look similar to this:

Id Refs Address    Size     Name
 1    6 0xc0100000 1cda44   kernel
 2    1 0xc02ce000 15648    coda.ko
 3    1 0xc0e1a000 7000     procfs.ko
 4    1 0xc0e28000 7000     ipfw.ko
 5    1 0xc0e4a000 15000    linux.ko
 6    1 0xc0e80000 2000     green_saver.ko
Coda module can be unloaded with kldunload coda . To get FreeBSD load Coda module automaticaly on system startup, you should add coda_load="YES" line to /boot/loader.conf .

Compiling Coda support into the custom kernel. For guidelines on compiling and installing new FreeBSD kernels, please refer to Configuring the FreeBSD Kernel chapter of the FreeBSD Handbook. Coda support requires including following lines into kernel configuration file:

options                   CODA                                         #CODA   filesystem.
pseudo-device       vcoda       4                               #coda   minicache   < - >   venus   comm.

This is the only Coda-specific modification requred.