Coda File System

Re: 5.3.14 compile problem

From: Jan Harkes <jaharkes_at_cs.cmu.edu>
Date: Mon, 21 May 2001 17:43:55 -0400
On Mon, May 21, 2001 at 05:25:18PM -0400, Ajay?S. Kang wrote:
> Hi,
> 
> I downloaded coda 5.3.14, lwp 1.7, rpc2 1.11 and rvm 1.4 and was able
> to configure and make lwp,rpc2 and rvm sucessfully. The configure
> script for coda also ran without errors. However when I ran make I
> got the following:

RedHat 7.1, I know.

I've already got a bunch of these fixed up, tried compiling using a
gcc-3.0 beta release. However I'm stuck at some very broken looking
varargs parsing code in venus/vol_cml.cc.

> another error. Since I didn't see any queries on the mailing list
> about this I suspect the error is not something as simple as a few
> missing #includes... Am I missing something in the make process?

No, you are just using a bleeding edge version of the gcc which is a lot
stricter about using functions without prototypes etc. Hopefully the
next Coda release will pass through the compiler correctly. You can also
grab a copy from our CVS tree and see how far that one gets you.

Jan
Received on 2001-05-21 17:43:57