Coda File System

Re: newbie question

From: Lucas <lucas_at_universogratis.com.ar>
Date: Tue, 18 Nov 2003 12:12:34 -0300 (ART)
Hello Ivan,

> Hello Lucas,
>
>> Below, my configuration:
>
> I see a couple of discrepancies that can mean that
> you made a small typing error or that your setup uses short hostnames
> (that would be wrong in general case) :
>
>> V_BindToServer: binding to host server1.domain.com
> ----------------------------------^^^^^^^^^^^^^^^^^^
>> GetVolumeList finished successfully
>>  server1 - success
>> V_BindToServer: binding to host server1
> ----------------------------------^^^^^^^
                                     ^Yes, that difference exist
                                      It's bad?
>
>> Client side:
>> venus-setup server1.domain1.com 100000
> ----------------------------^
> this one should not matter at all, though.
                                    This is only a typo, sorry
>
>> # cfs mkm /coda/server1.domain.com/lucas lucas
>> /coda/server1.domain.com: No such file or directory
>
> Has your client's /etc/hosts or your dns server the record for
> "server1.domain.com" ?
                        ^Yes, it has it (/etc/hosts)

>
>> # ll -a /coda/server1.domain.com
>> lrw-r--r--    1 root     65534          34 nov 18 11:29
>> /coda/server1.domain.com -> #@server1.domain.com [in red]
>
> It means that the client cannot find the server(s) for that realm.
> It uses dns or /etc/hosts or "realms" file in venus configuration.
> Have you got (some of) them, pointing to the right place?
> It would be sufficient to put
>
> xx.xx.xx.xx server1.domain.com
>
> (with corresponding address instead of "xx")
> in your /etc/hosts
>
                     I will try in the realms file!
> Hope it helps,
> --
> Ivan
Thank you Ivan!
Received on 2003-11-18 10:24:38