Coda File System

coda

From: Mark Hannessen <msh104_at_xs4all.nl>
Date: Sat, 20 Mar 2004 17:49:32 +0100
> make[2]: Entering directory `/progs/build/coda-6.0.3/coda-src/venus'
> g++ -fno-exceptions -fcheck-new -Wall -MD -DHAVE_CONFIG_H -I. 
> -I//progs/build/coda-6.0.3/include -I//progs/build/coda-6.0.3 -g -O2 -DVENUS 
> -DTIMING -DVENUSDEBUG -DRVM_USELWP -I//progs/build/coda-6.0.3/include  -c -o 
> worker.o worker.cc
> worker.cc: In function `void WorkerInit()':
> worker.cc:782: error: parse error before `[' token
> make[2]: *** [worker.o] Error 1
> make[2]: Leaving directory `/progs/build/coda-6.0.3/coda-src/venus'
> ----> Error in venus
> make[1]: *** [server-install] Error 1
> make[1]: Leaving directory `/progs/build/coda-6.0.3/coda-src'
> ----> Error in coda-src
> make: *** [server-install] Error 1

> Is this a know bug? and if yes, can I get arround it.

I got arround this but now and I got coda running.
I am up to the point that I can use venus to mount /coda
There does not seems to be anything odd.

17:35:04 Coda Venus, version 6.0.3

17:35:04 /usr/coda/LOG size is 564564 bytes
17:35:04 /usr/coda/DATA size is 2258256 bytes
17:35:04 Initializing RVM data...
17:35:04 ...done
17:35:04 Loading RVM data
17:35:04 Starting RealmDB scan
17:35:04        Found 1 realms
17:35:04 starting VDB scan
17:35:04        0 volume replicas
17:35:04        0 replicated volumes
17:35:04        0 CML entries allocated
17:35:04        0 CML entries on free-list
17:35:05 starting FSDB scan (833, 20000) (25, 75, 4)
17:35:05        0 cache files in table (0 blocks)
17:35:05        833 cache files on free-list
17:35:05 starting HDB scan
17:35:05        0 hdb entries in table
17:35:05        0 hdb entries on free-list
17:35:05 Initial LRDB allocation
17:35:05 Mounting root volume...
17:35:05 Venus starting...
17:35:05 /coda now mounted.

but when I try to login using clog it tells me that the coda auth2 server 
cannot be resolved.

root_at_xp2600s:/# clog codasys
username: codasys_at_xp2600pro
Password:
Unable to resolve addresses for Coda auth2 servers in realm 'xp2600pro'
Invalid login (RPC2_FAIL (F)).

But I can ping this machine using its hostname, IP and its FQDN.
I don't understand the problem. Anybody any hints for me on how to deal with 
this?

Thanks

Mark Hannessen.
Received on 2004-03-20 11:52:28