Coda File System

Re: createvol_rep failed on coda-6.9.0 and linux

From: S. Cance <stephane.cance_at_enst-bretagne.fr>
Date: Thu, 25 Jan 2007 19:42:47 +0100
Jan Harkes wrote:
> On Thu, Jan 25, 2007 at 05:51:04PM +0100, Reiner Dassing wrote:
>   
>> a new setup of coda-6.9.0 on Debian Linux did allow to createvol_rep
>> the default /vicepa but the command
>>
>> "createvol_rep iersdc tarzan1/vicepb tarzan2/vicepb"
>> shows: "Failed to dump the current VRDB into /vice/db/VRList.new"
>>     
>
> Did you set up /vice/db/vicetab to have a valid entry for /vicepb?
> Also, you may have to restart the servers before the new partition is
> picked up from that file.
>
>   
>> + volutil -h tarzan1 dumpvrdb /vice/db/VRList.new
>> + '[' 255 -ne 0 ']'
>> + echo 'Failed to dump the current VRDB into /vice/db/VRList.new'
>> Failed to dump the current VRDB into /vice/db/VRList.new
>> + exit 1
>>     
>
> If you run that volutil command from the prompt does it give an
> explanation for the error? In the script we redirected stderr to
> /dev/null to avoid too much clutter.
>
>   
>> # more /vice/vol/BigVolumeList
>> P/vicepa Htarzan1 T8b3f8c F8b3f78
>> W/.0 I1000001 H1 P/vicepa m0 M0 U2 W1000001 C45b88f7a D45b88f7a B0 A0
>>     
>
> This does look like we don't know about any vicepb 'partitions' on
> either tarzan1 or tarzan2, as there would be a P/vicepb line in the
> volume list. But maybe the script never got far enough to update this
> information.
>
> Jan
>   
Hello,


I am quite new to coda and I tried to install a coda system on an AMD64 
using debian (testing) in my school building from sources.

I just a similar problem, as indicated in the archives I checked that 
there was no problems of loopback address, and I deactivated ipv6 just 
in case. I also checked my files in /vice/db but they seems ok (most of 
them are just empty anyway). I tried to run a different vice-setup but 
it doesn't change anything.

In fact the truth is I don't understand how my install could work : I 
don't have any rpc2portmap daemon listening or even installed.
(netstat seems to indicate that nothing is waiting for rpc calls).
but I don't understand where I missed the thing either, I checked my 
install of rpc2 and it should be quite fine.

my dump is quite the same instead that /vice/vol/BigVolumeList doesn't 
exist.

I followed this wiki for tips on my install : 
http://coda.wikidev.net/The_Coda_Administration_and_User_Manual
and this for the configuration : 
http://linuxplanet.com/linuxplanet/tutorials/4481/5/

It fails on :
lina5:~# sh -x createvol_rep codaroot E0000100 /vicepa
+ prefix=/usr/local
+ exec_prefix=/usr/local
+ 
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/local/sbin
+ export PATH
+ vicedir=/vice
++ /usr/local/sbin/codaconfedit server.conf
+ . /usr/local/etc/coda/server.conf
++ numservers=1
++ vicedir=/vice
++ rvm_log=/usr/coda/logs/log_disk_file.log
++ rvm_data=/usr/coda/logs/data_disk_file.log
++ rvm_data_length=33554432
++ rvmtruncate=5
++ trace=100
++ allow_sha=1
+ '[' '!' -f /vice/hostname -o '!' -f /vice/db/scm ']'
++ cat /vice/hostname
++ cat /vice/db/scm
+ '[' lina5.lina-priv.enstb.org '!=' lina5.lina-priv.enstb.org ']'
+ '[' 3 -lt 2 ']'
+ SERVERS=
+ PARTITIONS=
+ NSERVERS=0
+ MAXSERVERS=8
+ VOLNAME=codaroot
++ echo codaroot
++ sed 's&/&\\/&g'
+ _VOLNAME=codaroot
+ '[' '!' -f /vice/db/VRList -a -f /vice/vol/VRList ']'
+ touch /vice/db/VRList
+ rm -f /vice/db/VRList.new
++ cat /vice/db/scm
+ volutil -h lina5.lina-priv.enstb.org dumpvrdb /vice/db/VRList.new
+ '[' 255 -ne 0 ']'
+ echo 'Failed to dump the current VRDB into /vice/db/VRList.new'
Failed to dump the current VRDB into /vice/db/VRList.new
+ exit 1

I think that I missed something simple but I really don't get where, I 
installed twice the system without any success...

I hope someone can help.

Regards,

P.S. : Sorry for my english, I try to be understood

-- 
Cance Stéphane
Third year Student
Received on 2007-01-25 15:08:45